Sempre que eu preciso reinstalar o ubuntu e tento rodar um projeto Rails tem o seguinte problema:

autodetect: Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

E sempre me esqueço que instalando o node.js e duas gems (execjs, therubyracer) o problema é resolvido:

gem "execjs"
gem "therubyracer"
sudo apt-get install nodejs

Bem, essa foi mais uma rapidinha...